Customer Notice

IMPORTANT NOTICE - ACTION REQUIRED

7th July 2020

We're getting in touch to let you know that we will soon be disabling three encryption versions on our shared email platform because they are out of date and do not meet our high levels of security.

These versions are:

SSLv3
TLS 1.1
TLS 1.0

We will be disabling these versions on 10th August 2020.

An important task for you

We need you to ensure that you are using the latest version of your email client. That's the most up to date version of Microsoft Outlook, Gmail, Mozilla Thunderbird and so on.

If you don't think you're using the latest version, you need to upgrade your software as promptly as you can.

Please note: if your email client is not up to date by 10th August 2020, you may experience disruption to your email services.

Any questions?

If you have any queries about any of this, please don't hesitate to contact us

Older Mail Apps

In most caces, you can continue to use older mail apps, however you will most likely need to disable the SSL for both incoming and outgoing mail servers

Port Numbers will need to be changed as follows:

Incoming Mail Server (POP): 110
Incoming Mail Server (IMAP): 143

Outgoing Mail Server can use 587 with or without SSL

Need help? Our Support Centre can help!

24/7 UK Support, Email any time or call +44 (0)330 0883541 +44 (0)330 0883541